You are running PHP 7.0.33-12+ubuntu16.04.1+deb.sury.org+1, but Grav needs at least PHP 7.1.3 to run.